Unofficial Nextion/TJC User Forum

NX4827T043_011 Firmware - Please help

Hi guys.

I have an issue after a firmware update with the latest version of Nextion Editor and my display seems to be non responsive with noise/lines all over.

I only have one 4.3inch NX4827T043_011 display here so I do not have another similar one for the memory dump.

I do however have a smaller NX3224T024_011 display that is still working, but I guess I am not able to use it’s firmware?

Any help would be much appreciated, I’ve been struggling so much to find a resolution to my issue.

Kind Regards
Jan

I believe the noise/lines all over means you under-voltaged your screen and it’s now dead or mostly dead. These screens are very sensitive to that sort of thing.

Hi there, I’ve checked the voltage and all seems fine, tried different sources etc. I think the firmware update bricked it by my understanding. When I try to download, it says “Invalid Devicenull”

I had the same issue. I contacted Itead Support (not Nextion Support) and they sent me a file to put on to SD card that fixed the issue.

1 Like

Hi @physke physke, thank you for the information. I will try get into contact with Itead and see what happens. Fingers crossed, haha.

Any way you can share the file in case your’s is NX4827T043_011 too?

Not sure if I can - PM me if you need it and I’ll figure it out

1 Like

Looks like the PM function is disabled here.

You can use this link to upload: https://www.dropbox.com/request/c6YPYgrw4lmsXjS5TVIo

Uploaded file to dropbox

Wait Ashot Tonoyan? Ape esel em Hay!!
Ene miamit jogi eli xosqi. Mekel, ete karas indz el uxarki eli proshivki link@, es TJC ekranner@ nenc em anum vor nextion vorpes haskanan eli.

Hahaha, vochinch mi mtaci kognenq, menak link@ jnji te che stex en kriseric kan eli nextion i.

Hey, could you also upload the file on to my dropbox, I bricked my NX4827T043_011 display too a while ago.

With SD card upload, the device screen will stay blank and the upload progress can not be seen, pls wait for about 20 seconds to make sure upload successfully, then power off, remove sd card, power on again. the device will be recovered.

After a uploading, a touch calibration is necessary.

1 Like

Hey, thanks for the uploading the file.

So I did what you said, but my display is still stuck showing noise line.
I also waited for a good 15 mins before removing the SD card & rebooting, still no luck, unfortunately.
I’m powering the display through the 5v from a FTDI breakout would that be an issue?

Hi Guys, @physke, @t_ashot

Could you please upload it for me too?

Much Appreciated

It could be. Try the process using a higher current power supply.

Done. Don’t forget to calibrate the touch screen after uploading it.

@physke

Thank you so much, I will give it a try tomorrow.

I had the same issue, can you help me, please

Hi!

I have same issue. Can you drop the file in my box?

Thank You!


This forum is in no way affiliated with NEXTION®, ITEAD STUDIO®, TJC®, or anyone else really. All product names, logos, and brands are property of their respective owners. All company, product, and service names used in this website are for identification purposes only. Use of these names, logos, and brands does not imply endorsement from the respective rights holder(s).