Card INIT ERROR Check your SD card is FAT32 even though it is!

Hello! I recently got a Nextion Discovery of 480x320 and it worked just fine with my SD card, up until now! I’m getting this weird error from the title that’s telling me I should check if my SD card was formatted with FAT32. Obviously it is since it worked just fine until now! I tried everything with 2 different cards, one of which is newer, but V10 which is recommended on the official website. I formatted them both on FAT32 with the Windows 11 formatter, and easeus:

None worked at all! What did work was using my USB-to-TTL which managed to download the .TFT file to the screen, but it was much slower than the SD cards. This issue could be related to SD card Init fail error - Is card formatted FAT32? . Do you guys have any idea what I should do? Or what might fix it?

I had a similar problem. See this post.

I tried this as well. I uploaded a program via TTL, then tried the SD card again but with no success… Are there any other ways we could fix it?