Unofficial Nextion/TJC User Forum

Wrong resource file or resource file damaged

Hello,
I have changed few months ago from the 3.2 (now not available) to the 3.5 enhanced LCD, thats been ok, (using the previous Editor version) but now (today) the Nextion Editor (before update to 1.63) getting error 'Wrong resource file or resource file damaged" . thought it may be the version so I did the update, and same error.

does anyone have a fix on that? there is not much on searches about it (that I can see)

I need to use the HMI converter, to transfer my work from Nex to TJC, as my client is China and knows the difference in costs.

the HMI converter has worked well to build tft in the USART

is there any changes to the HMI Converter?

thanks in advance.

appreciate it…

I have used the HMI converter with v1.63 and it‘s been working without issues so far.
For the TFT converter the story is different. The Nextion/TJC simulator will only run TFT files that match the exact editor version. The problem is that the TJC and the Nextion editor run their version numbers in a slightly different way. Nextion v1.63.3 is the same as TJC v1.63.1. What Nextion split into 1.63.1, 1.63.2 and 1.63.3 has been released all together as TJC 1.63.1 (or at least that seems to be the case; their release notes are not the most detailed…). Beside being unnecessarily confusing this effectively means that you cannot run a Nextion 1.63.3 TFT file in any TJC editor - because there is no 1.63.3.

While writing this I realize that it might be possible to fix this. During the conversion one could allow the user to specify a custom editor version. Maybe that‘ll be enough to fool the editor.

Kind regards,
Max

Max hi ok thanks, yes having the version selection in the converter would be good. as that may solve the problem. Unless there are usable versions that work on both.

Currently:

I have HMI files built with 1.61.2 (did in Sept) .

I need to convert these files for China customer, as I said it was ok , (and I retained the master TFT) but there is a new “splash” and Standby and I change the Chinese Logo, but now cant convert, all the language stuff is ok as that’s done in the ESP32 code.

I was running 1.62.2 and had not updated, but the other day I get message damaged resource files. updated to the new version , same error.

I see the TJC history has the 1.61.6 all rolled into the 1.61.n

when I open and save the project is Next 1.61.2, thats ok,
and convert it throws a warning re version.
but the USART cant open it, gets resource damaged.

so now cant convert files.

any thought?

thanks.


This forum is in no way affiliated with NEXTION®, ITEAD STUDIO®, TJC®, or anyone else really. All product names, logos, and brands are property of their respective owners. All company, product, and service names used in this website are for identification purposes only. Use of these names, logos, and brands does not imply endorsement from the respective rights holder(s).