Works with Simulator, but not when connected with micro-controller

This is my fist time using the NEXTION display with MCUs. I have a simple display: 2 pages displaying text and numbers all coming from the MCU. When I run the simulator using MCU input (on Serial port) it works correctly. When I change to the Serial2 port and connect the MCU to the display, the display does not show any of the data being sent. I have verified with a logic analyzer that Serial2 is working. I am monitoring the NEXTION Rx and Tx inputs with the logic analyzer I can see the data sent from the MCU to the display. The input data is at a 5v level.
I am looking for any suggestion/tips of what I can look at to try and determine what is happening in the display. I am using the 7" intelligent display.

Update: I verified that the arduino code works with the simulator. I’ve placed a logic analyzer on the input to the display and I can see a properly formatted command. I placed a logic analyzer on the display transmit and pressed several buttons and changed pages and the display is not transmitting, I verified that the display is powered by 5V and the data is at 5v. I would assume the display is bad, but I have a smaller display (5" intelligent display) and I get the same behavior. I also tried both wires assemblies that were provided with the displays and I made a third assemble to test with. For receive data I did try the Easy Nextion Library and sending properly formatted commands without using a library.
Any suggestions on next troubleshoot step or possible solutions would be greatly appreciated.

Thanks, Mike

Are you using the nextion library on the Arduino or just using Serial2.print?
Which Arduino device are you using?
Also show the line(s) from you IDE sketch indicating the print statements.
Whilst your analyser might show data being sent, if you don’t have the print syntax spot-on the nextion won’t accept.

Thank you for the reply. I am using the arduino Easy_Nextion_Library with an ESP32-S3. I was declaring an object called myNEX(Serial2). I tested all the commands with the simulator and fixed any issues with the commands I sent. I was able to test everything with the simulator. If you have time, I posted in the Arduino forum a lengthy explanation on the project, the hardware, and all the code. Here is the link:

I would appreciate any suggestions.


Issue resolved. Closed.

Could you please share the solution to your problem so it can help other users with similar problem in the future? Thanks.