Nextion tft file upgrade never works

I‘d like to come back to a critical issue I have with my 2,4 enhanced screen:
I use it under esphome and the tft file is in a home assistant directory.
2 weeks ago, I could make and work the upgrade but about 2 times over 3. The third time, the nextion displaid an error and the sole solution was to download it either with a sd card or with a usb to ttl adapter .
Now it never works and each tentative ends with an error message on the display after the upgrade.
During the upgrade, either it ends at 100 % then displays the error, or stop at around 95%.
I tried to make an esphome software with the strict minimum for connecting the screen. I tried to make a blank hmi as well.
I always get 100 % final brick.

I understood that the nextion software has a some limitation but software wise, I can’t understand why it somehow worked 2 weeks ago and refused to work now.

Perhaps there is an issue with my network ( I tried as well to disconnect everything except the esp, change WiFi point, etc ,)

Is there any way to get some log that could help me and the community for that issue ?
Thanks a lot by advance

No answer …
Am I the only one in the world with this issue ?

Hi pbranly,

I encountered the same issue. Set the baud rate in the uart section of your esphome yaml to 9600. The software UART of ESPHome is kinda janky so just set it to the default lower speed and it should work.

And also, just last week I was able to upgrade at 115,200bps.

Hi mikkogozalo,
But when ( several weeks ago) it was sometimes working, I had to use 115200. With 9600, it never worked.
Now it never work at both speed.
Tricky ……
I have fixed the issue by adding a small hole in my case, and I use a SD card with an extender
This is working but definitively not acceptable software wise !